Инструменты пользователя

Инструменты сайта


zabbix_v2

Содержание

Zabbix v2

Программа курса

Модуль 1: Развертывание IT инфраструктуры предприятия

Теория

Лабораторные работы: Развертывание объектов мониторинга

Настраиваем необходимый для мониторинга минимум из курса Администрирование сервисов UNIX с использованием Скрипты автоконфигурации

  • Для локальной сети использовать VirtualBox Host-Only Ethernet Adapte (понадобится в лабораторной работе про простые проверки и для подключения cisco switch ей в GNS)
  • Создать в Putty профили
  • Сервис DHCP (понадобится в лабораторной работе про LLD)
  • Финальная настройка DNS сервера (понадобится в лабораторной работе про простые проверки)
  • Настройка клиента DNS на gate и server
# cat /etc/resolv.conf
search corpX.un
nameserver 192.168.X.10
  • Запуск системы client1

Модуль 2: Установка компонентов Zabbix

Теория

Лабораторные работы: Развертывание компонентов Zabbix

Вопросы

  1. Какие версии Zabbix рекомендуются к использованию?
  2. Для каких задач используется Zabbix?
  3. Перечислите компоненты системы Zabbix.
  4. Верно ли, что система Zabbix позволяет осуществлять мониторинг только тех систем, на которых установлен агент?
  5. Перечислите, какие интерфейсы может использовать Zabbix для мониторинга?
  6. Есть ли возможность осуществлять мониторинг системы, не имеющей поддерживаемых Zabbix интерфейсов?

Модуль 3: Базовые сущности Zabbix

Теория

Лабораторные работы: Базовые элементы процесса мониторинга

Monitoring->Latest data
  ya.ru->check perf http ya.ru
  Zoom: 1h
  • Простые проверки доступности системы gate.isp.un и (не обязательно) сервиса RDP на windows client1 через server (методически лучше удалить host «Zabbix server» и добавить host server с адресом 127.0.0.1 и любым интерфейсом)
  • Настройка триггеров уведомляющего о недоступности gate.isp.un/ya.ru (с зависимостью друг от друга)
  • Отчет о проблемах
Monitoring->Triggers
  Group: all
  Host: all
  Triggers status: Problem
  Acknowledge status: With unack... events
gate# apt install wondershaper 

gate# wondershaper eth0 100 100

gate# wondershaper eth0

gate# wondershaper clear eth0
  • Настройка триггеров уведомляющего о ухудшении качества доступа в Интернет на основании повышения среднего времени ответа за период

Модуль 4: Использование шаблонов

Теория

Лабораторные работы: Управление конфигурацией с помощью шаблонов

4.1 Использование готовых шаблонов

  • Обзор шаблона «Template OS Linux»
  • Установка zabbix agent на server (Мониторинг с использованием Zabbix agents, можно оставить конфигурацию по умолчанию)
  • Применить к созданному host server шаблоны «Template OS Linux» и «Template App Zabbix Server»

4.2 Создание шаблона на основе существующего

gate# service ssh stop

gate# /usr/sbin/sshd -p 2222

gate# kill `cat /var/run/sshd.pid`

4.3 Настройка мониторинга статистики сервиса DHCP

  • Вариант 2 Использование UserParameter в zabbix-agent для мониторинга количества выданных ip сервисом DHCP (лучше уменьшить максимальное количество адресов до 10)
Configuration->Host->gate
  Items
    Name: dhcp.stat.CUR
      ...
          dhcp.stat.MAX
  Graphs
    Name: dhcp.stat.CUR.MAX
      ...

Модуль 5: Низкоуровневое обнаружение (LLD)

Теория

Лабораторные работы: Управление конфигурацией с помощью шаблонов и LLD

5.1 Первое знакомство с LLD

Configuration->Hosts->...->Items
                         ->Triggers
                         ->Graphs
                                ->Mounted filesystem discovery: ...
                                ->Network interface discovery: ...

5.2 Создание своего шаблона с LLD

  • Добавление подсетей (LAN2-eth2-VirtualBox_Адаптер 3_Внутренняя сеть) в сервис DHCP
gate# cat /etc/network/interfaces

gate# ifup eth2

gate# cat /etc/default/isc-dhcp-server

gate# cat /etc/dhcp/dhcpd.conf

gate# service isc-dhcp-server restart
  • Разработка шаблона, использующего Low-Level Discovery (LLD) для мониторинга использования адресного пространства DHCP сетей (как вариант, преподаватель разрабатывает шаблон и скрипты которые загружают слушатели)

Модуль 6: Управление уведомлениями

Теория

Лабораторные работы: Настройка уведомлений о событиях

  • Создать учетную запись userX с User type: «Zabbix Super Admin»
  • Включить userX в группу «Zabbix administrators»
  • Создать учетную запись user100+X с User type: «Zabbix User» и группой «Zabbix administrators»
  • Назначаем группе «Zabbix administrators» права на чтение всех объектов
  • Задание: вместо группы «Zabbix administrators» использовать новую, созданную «Zabbix responsible». Члены группы должны иметь права на просмотр результатов мониторинга и должны получать уведомления

Модуль 7: Активная регистрация оборудования

Теория

Лабораторные работы: Мониторинг систем с динамическими адресами

  • Преподаватель демонстрирует проблемы мониторинга windows систем с динамическими адресами (отключить фаервол, запустить агент в обычном режиме), !!! LLD в пассивном режиме использует имя системы, и, если его нет в DNS - не работает, для демонстрации можно в имени хоста использовать ip адрес, или рассказать про Настройка поддержки динамических обновлений от DHCP сервера в DNS
  • Активный режим zabbix-agent на client1
  • автоматическая регистрация агентов систем с динамическими IP параметрами
  • отключение уведомлений

Модуль 8: Мониторинг оборудования по протоколу SNMP

Теория

Лабораторные работы: Мониторинг сетевого оборудования

Развертывание оборудования

configure terminal

int vlan 1
ip address 192.168.13.2+N 255.255.255.0
no shutdown

snmp-server community public RO
end
copy running-config startup-config

Было:

configure terminal

hostname routerN
interface FastEthernet0/0
 ip address 172.16.1.19N 255.255.255.0
 no shutdown

ip route 0.0.0.0 0.0.0.0 172.16.1.254

ip name-server 172.16.1.254
ip domain-name isp.un
ip domain-lookup

snmp-server community public RO
end

copy running-config startup-config

Автоматическое добавление

Использование proxy

Модуль 9: Дополнительные возможности мониторинга в Zabbix

Теория

Лабораторные работы: Расширенные средства мониторинга и представления информации в Zabbix

zabbix_v2.txt · Последние изменения: 2019/03/19 15:56 — val