Инструменты пользователя

Инструменты сайта


общие_настройки_сетевого_оборудования_cisco

Общие настройки сетевого оборудования Cisco

Настройка времени

ntp server 172.16.1.254

clock timezone MSK 3

service timestamps log datetime localtime

Отключение http сервера

no ip http server

Ограничение доступа к vty

no access-list 1
! access-list 1 permit host 192.168.X.101
access-list 1 permit host 192.168.X.10
access-list 1 deny any

line vty 0 15
! no login ! for no password access
! privilege level 15
 access-class 1 in
end

Настройка SSH

Включение сервиса

Вариант 1

switch(config)#ip domain-name corpX.un
switch(config)#crypto key generate rsa general-keys modulus 1024
switch(config)#ip ssh version 2

switch(config)#ip scp server enable

switch(config)#username root privilege 15 secret cisco

switch(config)#line vty 0 4
switch(config-line)#login local
switch(config-line)#transport input ssh

Вариант 2

crypto key generate rsa label MY_KEYS modulus 1024
ip ssh rsa keypair-name MY_KEYS
ip scp server enable

Включение scp

ip scp server enable

Аутентификация по публичному ключу

root@helper:~# cat .ssh/id_rsa.pub
...

!!! Разбить вывод на несколько строк !!!

ip ssh pubkey-chain
username rancid
key-string
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC9KLTWwi8BTLMW6r79wgrfXrUOwai/smc
...
36w0k+JeK/WqJr5X80yX7fLbP root@helper
exit
exit
exit

Настройка rcmd сервисов

Включение сервисов

ip rcmd rcp-enable
ip rcmd rsh-enable

Настройка прав доступа

ip rcmd remote-host root server root enable

ip rcmd remote-host mrtg server mrtg enable
ip rcmd remote-host nagios server nagios enable
ip rcmd remote-host zabbix server zabbix enable

ip rcmd remote-host student mgmt student enable

Управление log сообщениями

Вывод логов на экран telnet сессии

router# terminal monitor

Вывод логов на экран console сессии

router(config)# logging console

Отправка логов на syslog сервер

router(config)#logging facility local0

router(config)#logging host server
        или
router(config)#logging host mgmt

Настройка snmp агента

Разрешение на чтение

router(config)# snmp-server community public RO

Разрешение на запись

switch(config)# snmp-server community write RW

Настройка адреса перехватчика trap сообщений

switch(config)# snmp-server host server writetrap

switch(config)# snmp-server host mgmt writetrap

Настройка генерации trap-ов в случае падения/поднятия интерфейсов

snmp-server enable traps snmp linkdown linkup

interface FastEthernet 0/2
 switchport mode access
 switchport access vlan 2
 storm-control broadcast level 1
 storm-control multicast level 1
 storm-control action trap

Использование RMON подсистемы протокола SNMP

Мониторинг изменения загрузки интерфейса router FastEthernet1/0

Определение OID (таблица соответствий имен переменных их числовым значениям в оборудовании может быть не полной)

server# snmptranslate .1.3.6.1.2.1.2.2.1
IF-MIB::ifEntry

server# snmptranslate -Tp .1.3.6.1.2.1.2.2.1

server# snmptranslate .1.3.6.1.2.1.2.2.1.10
IF-MIB::ifInOctets

server# snmpwalk -c public -v2c router ifDescr
...
IF-MIB::ifDescr.2 = STRING: FastEthernet1/0
...

server# snmpget -c public -v2c router ifEntry.10.2

server# snmpget -c public -v2c router ifInOctets.2

Настройка router:

snmp-server host server writetrap
rmon event 111 log trap writetrap description "Change bandwith" 
rmon alarm 222 ifEntry.10.2 10 delta rising-threshold 10000 111 falling-threshold 10000 111 

Коментарии:

  • event - кому посылать (в trap с комьюнити writetrap) и описание события
  • alarm - причины возникновения trap и привязка к event
  • Номер alarm (222) присутствует в OID trap
  • ifEntry.10.2 - (тоже что и ifInOctets.2 но коммутатор это не понимает)
  • 10 - период расчета в секундах
  • delta - считать относительно предыдущего параметра
  • rising-threshold 10000 111 - при превышении разницы значений счетчика на 10000 генерировать event 111
  • falling-threshold 10000 111 - при уменьшении разницы значений счетчика на 10000 генерировать event 111

Тестирование:

C:\>ping -n 1000 -l 1500 -w 1 172.16.1.254

server# tail -f /tmp/traps

Мониторинг загрузки процессора

rmon event 4 log trap public description "Cpu hight load"
rmon alarm 8 .1.3.6.1.4.1.9.2.1.56.0 10 absolute rising-threshold 80 4 falling-threshold 6 20
общие_настройки_сетевого_оборудования_cisco.txt · Последние изменения: 2019/08/13 10:28 — val